R包r gdal在CentOS 6中不重新调整gdal版本

时间 2019-02-09
阅读 25
点赞 0
收藏 0
连接matthew-hamilton

我正在尝试在R版本3.5.1的CentOS 6.10上安装包rgdal。我有gdal版本1.7.3和proj版本4.7.0-1。当我跑步的时候:

$ sudo -i R
> install.packages("rgdal")

我有点幽默的错误:

configure: GDAL: 1.7.3
checking GDAL version >= 1.11.4... no
configure: error: upgrade GDAL to 1.11.4 or later
ERROR: configuration failed for package ‘rgdal’
* removing ‘/usr/lib64/R/library/rgdal’

rgdal cran页面说你需要gdal 1.1或更高版本,但我有gdal 1.7.3。这是个问题吗?如果是这样,您如何在CentOS上降级gdal?如何安装兼容版本的gdal或让r识别当前版本?

我已尝试卸载、重新安装和重新启动:

$ sudo yum remove gdal proj
$ sudo yum install gdal gdal-devel
$ sudo yum install proj proj-nad proj-epsg

我尝试过许多其他版本的rgdal,结果都是相同的错误:

> install.packages("rgdal", version = "1.2-3")

这个问题模仿了我一直在关注的一个长期未回答的问题:rgdal doesn't recognize GDAL version

尚无答案